Последние сообщения

Страницы: 1 [2] 3 4 ... 10
11
UP! еще в наличии
Цена снижена :)
12
UP!  ЕЩЕ В НАЛИЧИИ И В КОЛИЧЕСТВЕ! :)
13
UP! ЕЩЕ ПРОДАЖЕ :)
15
Обход блокировки сайтов на Mikrotik при помощи Policy Based Routing. v2

Сегодня мы не будем рассматривать все методы обхода всех видов блокировки, а лишь рассмотрим один из вариантов реализации обхода, который предложен в официальной документации Mikrotik (Policy Based Routing).

Предполагается, что заранее у вас уже должен быть маршрутизатор на RouterOS, если такого не имеется - по выгодной цене маршрутизаторы Mikrotik можно приобрести *** ссылки только после регистрации или входа или *** ссылки только после регистрации или входа ;)

Наиболее простой вариант обхода – использовать серверы VPN. Причем заблокированные ресурсы можно открывать через VPN, а все оставшиеся – через провайдера.
У данного метода существует ряд преимуществ. Одно из главных достоинств данного метода состоит в том, что вы будете использовать лишь часть пропускной способности VPN. Дело в том, что сервисы VPN обычно находятся далеко заграницей и каналы к ним сильно загружены, поэтому направляя через тоннель весь трафик, скорость доступа будет падать, причем как для заблокированных ресурсов, так и для всех остальных.
Из дополнительных преимуществ данного метода можно отметить отсутствие необходимости настройки VPN на всех клиентских устройствах, особенно если это смартфон. Хотя для смартфонов существует достаточное количество бесплатных приложений, реализующих необходимый функционал. Есть у данного способа и недостаток – поиск оптимального VPN-сервиса, как вариант, покупка премиум-аккаунта.

Создание списка адресов
К примеру, у нас есть листинг из заблокированных адресов.
В качестве примера у нас список, ВКонтакте, Одноклассники, Yandex и Mail.ru +kinopoisk.ru
Адреса можно добавлять и вручную через терминал из WinBox > New Terminal, но это мучительно долго и муторно)
Все диапазоны в виде скрипта закачки и добавления в Mikrotik для простоты уже созданы на сайте *** ссылки только после регистрации или входа

В микротике создаем скрипт zaboronaBlockLiST закачки и установки списка диапазонов IP заблокированных сайтов
и копируем туда этот код (заменяем xxxx на логин и пароль выданный мною)

Код: *** ссылки только после регистрации или входа
:local sblPath "/zaboronaBL.rsc"
:log warning "Downloading zaboronaBL.rsc to $sblPath"
/tool fetch address=blacklist.pp.ua host=blacklist.pp.ua user=xxxx mode=https password=xxxxx src-path=/bl/zaboronaBL.rsc dst-path=$sblPath;

:log warning "Importing zaboronaBL.rsc from $sblPath"
/import  $sblPath;

И смотрим появившийся список адресов в разделе IP – Firewall – Address Lists.

Маркировка пакетов
Для того, чтобы отобрать только заблокированные ресурсы, необходимо найти и промаркировать необходимые пакеты.
Делается это в IP – Firewall – Mangle. При создании указываем следующие параметры: chain=prerouting action=mark-routing dst-address-list=zaboronaBL (список адресов) src-address=192.168.1.0/24 (локальная подсеть) Вместо 192.168.1.0/24 необходимо указывать свою локальную подсеть, из которой будут идти обращения.

Как несложно догадаться, dst-address-list это конечный адрес (из списка).

Для всего трафика, удовлетворяющего данным условиям, будет установлена соответствующая метка Traffic_zaboronaBL.

Код: *** ссылки только после регистрации или входа
/ip firewall mangle
add action=mark-routing chain=prerouting comment="Mark Zaborona BlockList" dst-address-list=zaboronaBL new-routing-mark=Traffic_zaboronaBL passthrough=no src-address=192.168.1.0/24

Создание VPN-подключения
Покупаем себе VPS сервер в любо свободной стране) устанавливаем систему и любой из VPN PPTP, 2LTP+IPSEC или OpenVPN ;)

Создание подключения к VPN осуществляется в разделе PPP – Interface, нажимаем синий плюс и выбираем необходимый тип подключения.

Код: *** ссылки только после регистрации или входа
/interface pptp-client
add comment="PPTP VPN" connect-to=ВАШ ДОМЕН disabled=no name=pptp-vpn password=xxx user=xxx

Важно! Не используйте опцию «Add Default Route», в противном случае весь трафик пойдет через VPN.

Обратите внимание, некоторые серверы могут, как требовать шифрование, так и не использовать его вовсе, поэтому если соединение не удалось – проверьте используемый профиль подключения (PPP – Profiles). Для PPTP, в лучшем случае, используется MPPE 128-bit, который уже давным-давно скомпрометирован.

Лучшим вариантом будет использование OpenVPN, ну или L2TP/IPsec.

Большинство бесплатных серверов могут быть нестабильны как в плане доступности, так и в плане скорости. К тому же, никто не гарантирует сохранности ваших личных данных. С учетом вышесказанного, к выбору поставщика услуг стоит подойти ответственно. Как минимум, всегда используйте защищенное соединение (HTTPS) при работе с сайтами. Самый лучший вариант, это купить свой личный VPS и там установить любую Linux/Unix систему. ;)

Настройка маскарадинга
Сам Mikrotik уже знает про новый шлюз, а для того, чтобы ресурсами VPN-канала смогли пользоваться другие пользователи локальной сети, необходимо настроить маскарадинг.

Делается это в разделе IP – Firewall – NAT. Для out-interface обязательно следует указать правильное название вашего VPN-подключения.

Код: *** ссылки только после регистрации или входа
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pptp-vpn comment="PPTP VPN"

Добавление статических маршрутов
После настройки маскарадинга переходим к завершающему шагу – созданию статических маршрутов. Делается это в разделе IP – Routers.

Код: *** ссылки только после регистрации или входа
/ip route
add comment="Route zaboronaBL" distance=1 gateway=pptp-vpn routing-mark=Traffic_zaboronaBL

При создании маршрутов конечный адрес задаем как и для обычного интернет подключения –0.0.0.0/0, в качестве шлюза (gateway) необходимо указать VPN-подключение (в нашем случае pptp-vpn). Обязательно выбираем routing-mark из выпадающего списка. Таким образом мы создаем статический маршрут для промаркированного трафика.

Вот собственно и всё, если всё проделано верно, а VPN рабочий – вы сможете получить доступ к необходимым ресурсам.
Также можете почитать официальную документацию Mikrotik по Policy Base Routing.

Как узнать IP определенного сайта?
Чуть выше, в качестве примера, опубликованы общие списки IP-адресов и диапазонов, принадлежащих соответствующим ресурсам. Списки предоставлен как есть, без претензий к их точности. Настоятельно рекомендую формировать список самостоятельно, так сказать «под себя».
В случае с обычными интернет-сайтам, обычно требуется добавить всего 1-2 IP-адреса, в то время как для больших проектов может использоваться несколько диапазонов. Как же найти все IP по определенному сайту?

В качестве наиболее простого варианта, из под Windows (вызов командной строки – комбинация Win+R) можно использовать стандартную команду:

Код: *** ссылки только после регистрации или входа
nslookup <домен>
Недостатком такого метода является получение неполного списка адресов.
Для поиска наиболее полного списка всех адресов, можно *** ссылки только после регистрации или входа. При помощи поиска от Hurricane Electric, можно производить поиск, как по доменному домену (например, youtube.com), так и по названию компании, которая владеет пулом адресов (например, Youtube либо YouTube, LLC).


Редактирование, обновление и добавление новых ресурсов
Еще одним неоспоримым преимуществом раздельных списков является то, что в любой момент можно добавлять, удалять или изменять отдельные списке, при этом остальные ресурсы не будут затронуты.


Ну и, конечно же, чтобы начать обработку нового списка, необходимо создать новый мангл (промаркировать пакеты) и статический маршрут для нового списка (общий принцип описан выше).

Что делать, если Policy Based Routing медленно работает?
На некоторых конфигурациях может возникнуть проблема, суть которой состоит в том, что при прямом подключении по VPN на ПК – всё работает быстро, но если настроить Policy Based Routing по вышеуказанному примеру в Mikrotik, сайты начинают открываются медленно.

Проблема решается отключением FastTrack в IP – Firewall – Filter Rules.





Поддержка FastTrack была добавлена, начиная с RouterOS 6.29, если кратко, функция позволяет пересылать некоторые пакеты без дополнительно обработки. В некоторых конфигурациях, данная функция позволяет существенно (в несколько раз) ускорить обработку пакетов и понизить нагрузку на процессор.


PS. Так же есть готовый сервис OpenVPN с настроками под Mikrotik:  *** ссылки только после регистрации или входа
      Но там минусы в том, что старые IP не часто обновляются и их изменить никак) они создаются при подключении в роутинге :)
      И для параноиков так же очевидно, что на серверах РФ могут перехватывать ssl трафик и получать Ваши пароли :(

      И ввиду большой популярности сервиса у него уже начинаются *** ссылки только после регистрации или входа) потому свой VPS всегда надежнее и безопаснее)
     
16
Записки администратора / Re: BlackList для Mikrotik и не только :)
« Последний ответ от skameykin22 Апреля 16, 2018, 06:09:45 pm »
Полезная информация.
17
Записки администратора / BlackList для Mikrotik и не только :)
« Последний ответ от Дмитрий Марта 27, 2018, 06:39:29 pm »
К сожалению все хорошее когда-нибудь да кончается (:

    Вот и щас с прекрасным проектом Давида Ждойса  BlackList, его Черным Списком злодеев в инете, тоже печалька (:
    Пришла печальная новость о его закрытии  :-\ ,  обитал на форуме микротика по этому адресу: *** ссылки только после регистрации или входа

Но не долго думая и пережив эту нелегкую потерю,  :-* мы задумали сделать сами обновляемый свой *** ссылки только после регистрации или входа

На сервере каждые 2 часа генерируется и фильтруется от дубликатов наш собственный список злодеев (:

по адресу:
Код: *** ссылки только после регистрации или входа
https://ix-ua.net/BlackList.rsc   (это бесплатно)
https://ix-ua.net/bl/BlackListFull.rsc   (полный список)
https://ix-ua.net/bl/TornodesList.rsc  (обновляемый каждый час список всех серверов Tor)
и настоятельно рекомендую полную версию использовать только для роутеров с оперативкой >= 64Мб !!...

Лист генерируется с таких списков как: blocklist.de, dshield.org,  spamhaus.org, openbl.org, zeustracker.abuse.ch, malc0de.com и др.

Вам остается только на роутере сделать простенький скриптик его обновления:

Код: *** ссылки только после регистрации или входа
# File path for BlackList. Change to use attached storage if available (e.g. "disk1/BlackList.rsc")

:local sblPath "/BlackList.rsc"
:log warning "Downloading BlackList.rsc to $sblPath"
/tool fetch address=ix-ua.net host=ix-ua.net mode=https src-path=/BlackList.rsc dst-path=$sblPath;

:log warning "Importing BlackList.rsc from $sblPath"
/import  $sblPath;

Дальше проверяйте его, нажав Run Script на фоне окна с логами и читаем отчет о ходе обновления...

чтобы это было по расписанию и при загрузке роутера делаем две записи в Scheduler:

Код: *** ссылки только после регистрации или входа
/system script run BlackList
подписываем его BlackListUpdate и ставим интервал обновления  6 часов, например, все равно некоторые списки обновляются раз в день, а некоторые раз в неделю, так что не стоит так часто ставить обновление :P

Код: *** ссылки только после регистрации или входа
:delay 15;
/system script run BlackList

эту запись делаем для того чтобы сразу при загрузке мы обновили динамические записи адресов злoдиев :) ..,
указав Startup вместо интервала обновления, как в предыдущей записи. И подписываем запись BlackListUpdateOnBoot.

И наслаждаемся !!

Тоже самое заодно сделали и для Тор сайтов или как их называют Tor Nodes

Список всех нодов торента обновляется каждые 40 минут по адресу:
Код: *** ссылки только после регистрации или входа
http://ix-ua.net/bl/TornodesList.rsc
Скрипт его обновления, где меняем пользователя и его пароль на выданные :
Код: *** ссылки только после регистрации или входа
# File path for TornodesList.rsc lacklist. Change to use attached storage if available (e.g. "disk1/TornodesList.rsc")

:local sblPath "/TornodesList.rsc"
:log warning "Downloading TornodesList.rsc to $sblPath"
/tool fetch address=ix-ua.net host=ix-ua.net user=пользователь mode=https password=пароль src-path=/bl/TornodesList.rsc dst-path=$sblPath;

:log warning "Importing TornodesList.rscc from $sblPath"
/import  $sblPath;

доступ к полному черному списку и Tor серверов запаролен и платный 1$ в месяц, обращайтесь :)

Остальное на собственном сайте черных списков: *** ссылки только после регистрации или входа or *** ссылки только после регистрации или входа
18

    MikroTik hEX (модель RB750Gr3) — это гигабитный роутер без Wi-Fi с поддержкой аппаратного шифрования IPsec.



    Маршрутизатор оснащен пятью гигабитными сетевыми портами, полноразмерным портом USB 2.0 для подключения 3G/4G модемов
    или внешних накопителей, и слотом microSD для установки карт памяти.


Внутри устройства установлен двухъядерный процессор с частотой 880 МГц, работающий в 4 потока и поддерживающий аппаратное шифрование IPsec. При использовании алгоритма шифрования AES-128 с пакетами размером 1400 байт вы получите скорость до 472 Мбит/с. Оперативная память составляет 256 MБ.

Роутер можно удаленно запитать по сетевому кабелю по технологии POE. Для этого понадобится докупить гигабитный POE инжектор.

В MikroTik RB750Gr3 установлена операционная система RouterOS Level4 с огромными возможностями по настройке. С ее помощью вы сможете ограничить скорость пользователям, запретить доступ к социальным сетям или торрентам, сделать в кафе или гостинице HotSpot с перенаправлением на рекламную страничку, организовать защищенное подключение к офису удаленных сотрудников или филиалов по VPN и многое другое.

Также маршрутизатор поддерживает установку The Dude Server, предназначенного для мониторинга в сети различных устройств, серверов, сервисов, установки связей между ними и оповещении при сбоях.

Купить MikroTik hEX (модель RB750Gr3) выгодно, поскольку он имеет хорошую производительность, поддержку аппаратного шифрования IPsec, The Dude Server и доступную цену.

   Характеристики:

   Процессор: MT7621A 880 МГц, 2 ядра и 4 потока
   RAM: 256 MB
   Flash: 16 MB
   Разъемы: 5×10/100/1000 Mbit/s Ethernet RJ45
   1×USB 2.0   1×MicroSD slot
   ОС: MikroTik RouterOS Level4
   Электропитание: PoE: 8..30 V DC on Ethernet port1
   jack:8..30 V DC
   Потребление: до 5 Вт
   Размеры: 113 × 89 × 28 мм  Вес: 129 г
   Рабочая температура: от -30°C до +70°С

ЦЕНА 1400 грн

Сайт производителя *** ссылки только после регистрации или входа

*** ссылки только после регистрации или входа

Поедет Новой Почтой по предоплате

В Днепре забирать пр. Гагарина,3.
Это пересечение пр. Гагарина и пр. Яворницкого (К.Маркса)
Могу встретить Вас около танка c 10:00 до 20:00

Звоните!

(O6З) 125-O2-O2
Страницы: 1 [2] 3 4 ... 10