iforum.pp.ua

Основной каталог => IT технологии и др. => Записки администратора => Тема начата: Дмитрий от Января 21, 2021, 12:56:57 pm

Название: MikroTik поддерживает DNS over HTTPS (DoH)
Отправлено: Дмитрий от Января 21, 2021, 12:56:57 pm
MikroTik поддерживает DNS over HTTPS (DoH)

Начиная со стабильной версии 6.47 MikroTik поддерживает DNS over HTTPS (DoH).
Далее краткая инструкция по настройке с проверкой сертификата сервера на примере Cloudflare.

1) Импортируем сертификат DigiCert Global Root CA в хранилище сертификатов роутера:

Код: You are not allowed to view links. Register or Login
/tool fetch url=https://cacerts.digicert.com/DigiCertGlobalRootCA.crt.pem
Код: You are not allowed to view links. Register or Login
/certificate import file-name=DigiCertGlobalRootCA.crt.pem passphrase=""
2) В поле Use DoH Server пишем https://1.1.1.1/dns-query и ставим галку Verify DoH Certificate:

Код: You are not allowed to view links. Register or Login
/ip dns set use-doh-server=https://1.1.1.1/dns-query verify-doh-cert=yes
3) Убираем все существующие DNS-сервера, чтобы поля Servers и Dynamic Servers (из DHCP Client) были пустыми
и все запросы шли через DNS over HTTPS   (не обязательно для 6.47.1+).

Код: You are not allowed to view links. Register or Login
/ip dns set servers=""

Можете использовать других поставщиков DoH,  например, 9.9.9.9  8)  DoH with Quad9 DNS Servers (https://www.quad9.net/news/blog/doh-with-quad9-dns-servers/)

У вас уже есть они все в корневом сертификате ;)

Код: You are not allowed to view links. Register or Login
/ip dns set use-doh-server=https://dns.quad9.net/dns-query verify-doh-cert=yes
/ip dns set servers=""

Подробнее смотрим все на сайте DNS-over-HTTPS (DoH) (https://dnsprivacy.org/public_resolvers/#dns-over-https-doh)