Автор Тема: MikroTik поддерживает DNS over HTTPS (DoH)  (Прочитано 225 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Дмитрий

  • Global Moderator
  • Jr. Member
  • *****
  • Сообщений: 70
  • Country: ua
  • Karma: +1/-0
  • Пол: Мужской
  • ICQ: 41488731
MikroTik поддерживает DNS over HTTPS (DoH)
« : Января 21, 2021, 12:56:57 pm »
MikroTik поддерживает DNS over HTTPS (DoH)

Начиная со стабильной версии 6.47 MikroTik поддерживает DNS over HTTPS (DoH).
Далее краткая инструкция по настройке с проверкой сертификата сервера на примере Cloudflare.

1) Импортируем сертификат DigiCert Global Root CA в хранилище сертификатов роутера:

Код: *** ссылки только после регистрации или входа
/tool fetch url=https://cacerts.digicert.com/DigiCertGlobalRootCA.crt.pem
Код: *** ссылки только после регистрации или входа
/certificate import file-name=DigiCertGlobalRootCA.crt.pem passphrase=""
2) В поле Use DoH Server пишем *** ссылки только после регистрации или входа и ставим галку Verify DoH Certificate:

Код: *** ссылки только после регистрации или входа
/ip dns set use-doh-server=https://1.1.1.1/dns-query verify-doh-cert=yes
3) Убираем все существующие DNS-сервера, чтобы поля Servers и Dynamic Servers (из DHCP Client) были пустыми
и все запросы шли через DNS over HTTPS   (не обязательно для 6.47.1+).

Код: *** ссылки только после регистрации или входа
./ip dns set servers=""
Можете использовать других поставщиков DoH,  например, Google: 
Код: *** ссылки только после регистрации или входа
https://dns.google/dns-queryУ вас уже есть они все корневом сертификате ;)

Подробнее смотрим все на сайте *** ссылки только после регистрации или входа
« Последнее редактирование: Января 21, 2021, 01:04:05 pm от Дмитрий »


  • 1o1o1@xmpp.jp
Files archive *** ссылки только после регистрации или входа