Автор Тема: BlackList для Mikrotik и не только :)  (Прочитано 2656 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Дмитрий

  • Global Moderator
  • Jr. Member
  • *****
  • Сообщений: 70
  • Country: ua
  • Karma: +1/-0
  • Пол: Мужской
  • ICQ: 41488731
BlackList для Mikrotik и не только :)
« : Марта 27, 2018, 06:39:29 pm »
К сожалению все хорошее когда-нибудь да кончается (:

    Вот и щас с прекрасным проектом Давида Ждойса  BlackList, его Черным Списком злодеев в инете, тоже печалька (:
    Пришла печальная новость о его закрытии  :-\ ,  обитал на форуме микротика по этому адресу: You are not allowed to view links. Register or Login

Но не долго думая и пережив эту нелегкую потерю,  :-* мы задумали сделать сами обновляемый свой You are not allowed to view links. Register or Login

На сервере каждые 2 часа генерируется и фильтруется от дубликатов наш собственный список злодеев (:

по адресу:
Код: You are not allowed to view links. Register or Login
https://blacklist.pp.ua/BlackList.DEMO.rsc   (это DEMO бесплатно)
https://blacklist.pp.ua/bl/BlackListFull.rsc   (полный список)
https://blacklist.pp.ua/bl/TornodesList.rsc  (обновляемый каждый час список всех серверов Tor)
и настоятельно рекомендую полную версию использовать только для роутеров с оперативкой >= 64Мб !!...

Лист генерируется с таких списков как: blocklist.de, dshield.org,  spamhaus.org, openbl.org, zeustracker.abuse.ch, malc0de.com и др.

Вам остается только на роутере сделать простенький скриптик его обновления:

Код: You are not allowed to view links. Register or Login
# File path for BlackList. Change to use attached storage if available (e.g. "disk1/BlackList.rsc")

:local sblPath "/BlackList.rsc"
:log warning "Downloading BlackList.rsc to $sblPath"
/tool fetch address=blacklist.pp.ua host=blacklist.pp.ua mode=https src-path=/BlackList.rsc dst-path=$sblPath;

:log warning "Importing BlackList.rsc from $sblPath"
/import  $sblPath;

Дальше проверяйте его, нажав Run Script на фоне окна с логами и читаем отчет о ходе обновления...

чтобы это было по расписанию и при загрузке роутера делаем две записи в Scheduler:

Код: You are not allowed to view links. Register or Login
/system script run BlackList
подписываем его BlackListUpdate и ставим интервал обновления  6 часов, например, все равно некоторые списки обновляются раз в день, а некоторые раз в неделю, так что не стоит так часто ставить обновление :P

Код: You are not allowed to view links. Register or Login
:delay 15;
/system script run BlackList

эту запись делаем для того чтобы сразу при загрузке мы обновили динамические записи адресов злoдиев :) ..,
указав Startup вместо интервала обновления, как в предыдущей записи. И подписываем запись BlackListUpdateOnBoot.

И наслаждаемся !!

Тоже самое заодно сделали и для Тор сайтов или как их называют Tor Nodes

Список всех нодов торента обновляется каждые 40 минут по адресу:
Код: You are not allowed to view links. Register or Login
http://blacklist.pp.ua/bl/TornodesList.rsc
Скрипт его обновления, где меняем пользователя и его пароль на выданные :
Код: You are not allowed to view links. Register or Login
# File path for TornodesList.rsc lacklist. Change to use attached storage if available (e.g. "disk1/TornodesList.rsc")

:local sblPath "/TornodesList.rsc"
:log warning "Downloading TornodesList.rsc to $sblPath"
/tool fetch address=blacklist.pp.ua host=blacklist.pp.ua user=пользователь mode=https password=пароль src-path=/bl/TornodesList.rsc dst-path=$sblPath;

:log warning "Importing TornodesList.rscc from $sblPath"
/import  $sblPath;

доступ к полному черному списку и Tor серверов запаролен и платный 1$ в месяц, обращайтесь :)

Остальное на собственном сайте черных списков: You are not allowed to view links. Register or Login or You are not allowed to view links. Register or Login
« Последнее редактирование: Августа 18, 2022, 12:41:06 am от Дмитрий »


Contact You are not allowed to view links. Register or Login    

Оффлайн skameykin22

  • Newbie
  • *
  • Сообщений: 1
  • Country: ru
  • Karma: +0/-0
  • Пол: Мужской
  • ICQ: 657564
Re: BlackList для Mikrotik и не только :)
« Ответ #1 : Апреля 16, 2018, 06:09:45 pm »
Полезная информация.