Автор Тема: Как заставить издавать Mikrotik мелодию  (Прочитано 3389 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Дмитрий

  • Global Moderator
  • Jr. Member
  • *****
  • Сообщений: 70
  • Country: ua
  • Karma: +1/-0
  • Пол: Мужской
  • ICQ: 41488731
Как заставить издавать Mikrotik мелодию
« : Февраля 28, 2018, 05:32:25 pm »
Заходим в WinBox на микротик с бипером желательно)

дальше добавляем скрипт с командами бипира:

SYSTEM-> Scripts и жмем плюсик)

обзываем скрипт сразу и копируем содержимое...

чтобы запускать скрипты при старте или по расписанию лезем в SYSTEM-> Sheduler
создаем там расписание и указываем в поле что делать: запускать скрипт: /system script run StarWars
Код: You are not allowed to view links. Register or Login
:delay 4;
/system script run StarWars

:delay 4; – это сколько секунда ждать...  ;)


Вот примеры наиболее популярных композиций:

StarWars Imperial   домашний Дарт Вейдер :) у вас в роутере

Код: You are not allowed to view links. Register or Login
:beep frequency=500 length=500ms;:delay 500ms;
:beep frequency=500 length=500ms;:delay 500ms;
:beep frequency=500 length=500ms;:delay 500ms;
:beep frequency=400 length=500ms;:delay 400ms;
:beep frequency=600 length=200ms;:delay 100ms;
:beep frequency=500 length=500ms;:delay 500ms;
:beep frequency=400 length=500ms;:delay 400ms;
:beep frequency=600 length=200ms;:delay 100ms;
:beep frequency=500 length=500ms;:delay 1000ms;


:beep frequency=750 length=500ms;:delay 500ms;
:beep frequency=750 length=500ms;:delay 500ms;
:beep frequency=750 length=500ms;:delay 500ms;
:beep frequency=810 length=500ms;:delay 400ms;
:beep frequency=600 length=200ms;:delay 100ms;
:beep frequency=470 length=500ms;:delay 500ms;
:beep frequency=400 length=500ms;:delay 400ms;
:beep frequency=600 length=200ms;:delay 100ms;
:beep frequency=500 length=500ms;:delay 1000ms;

StarWar Imperial 2

Код: You are not allowed to view links. Register or Login
:beep frequency=587 length=402ms;
:delay 412ms;
:delay 134ms;

:beep frequency=587 length=402ms;
:delay 412ms;
:delay 134ms;

:beep frequency=587 length=402ms;
:delay 412ms;
:delay 134ms;

:beep frequency=466 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=698 length=134ms;
:delay 144ms;
:beep frequency=587 length=402ms;
:delay 412ms;
:delay 134ms;

:beep frequency=466 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=698 length=134ms;
:delay 144ms;
:beep frequency=587 length=804ms;
:delay 814ms;
:delay 268ms;

:beep frequency=880 length=402ms;
:delay 412ms;
:delay 134ms;

:beep frequency=880 length=402ms;
:delay 412ms;
:delay 134ms;

:beep frequency=880 length=402ms;
:delay 412ms;
:delay 134ms;

:beep frequency=932 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=698 length=134ms;
:delay 144ms;
:beep frequency=554 length=402ms;
:delay 412ms;
:delay 134ms;

:beep frequency=466 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=698 length=134ms;
:delay 144ms;
:beep frequency=587 length=804ms;

StarWars ImperialFull

Код: You are not allowed to view links. Register or Login
:beep frequency=587 length=402ms;
:delay 412ms;
:delay 134ms;

:beep frequency=587 length=402ms;
:delay 412ms;
:delay 134ms;

:beep frequency=587 length=402ms;
:delay 412ms;
:delay 134ms;

:beep frequency=466 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=698 length=134ms;
:delay 144ms;
:beep frequency=587 length=402ms;
:delay 412ms;
:delay 134ms;

:beep frequency=466 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=698 length=134ms;
:delay 144ms;
:beep frequency=587 length=804ms;
:delay 814ms;
:delay 268ms;

:beep frequency=880 length=402ms;
:delay 412ms;
:delay 134ms;

:beep frequency=880 length=402ms;
:delay 412ms;
:delay 134ms;

:beep frequency=880 length=402ms;
:delay 412ms;
:delay 134ms;

:beep frequency=932 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=698 length=134ms;
:delay 144ms;
:beep frequency=554 length=402ms;
:delay 412ms;
:delay 134ms;

:beep frequency=466 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=698 length=134ms;
:delay 144ms;
:beep frequency=587 length=804ms;
:delay 814ms;
:delay 268ms;

:beep frequency=1175 length=402ms;
:delay 412ms;
:delay 134ms;

:beep frequency=587 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=587 length=134ms;
:delay 144ms;
:beep frequency=1175 length=268ms;
:delay 278ms;
:delay 268ms;

:beep frequency=1109 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=1047 length=134ms;
:delay 144ms;
:beep frequency=988 length=134ms;
:delay 144ms;
:beep frequency=932 length=134ms;
:delay 144ms;
:beep frequency=988 length=268ms;
:delay 278ms;
:delay 268ms;

:beep frequency=622 length=134ms;
:delay 144ms;
:delay 134ms;

:beep frequency=831 length=268ms;
:delay 278ms;
:delay 268ms;

:beep frequency=784 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=740 length=134ms;
:delay 144ms;
:beep frequency=698 length=134ms;
:delay 144ms;
:beep frequency=659 length=134ms;
:delay 144ms;
:beep frequency=698 length=268ms;
:delay 278ms;
:delay 268ms;

:beep frequency=466 length=134ms;
:delay 144ms;
:delay 134ms;

:beep frequency=554 length=1071ms;
:delay 1081ms;

StarWar ImperialFull2

Код: You are not allowed to view links. Register or Login
:beep frequency=784 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=784 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=784 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=622 length=201ms;
:delay 211ms;
:delay 67ms;

:beep frequency=932 length=100ms;
:delay 110ms;
:beep frequency=784 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=622 length=201ms;
:delay 211ms;
:delay 67ms;

:beep frequency=932 length=100ms;
:delay 110ms;
:beep frequency=784 length=536ms;
:delay 546ms;
:delay 268ms;

:delay 67ms;

:beep frequency=1175 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=1175 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=1175 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=1245 length=201ms;
:delay 211ms;
:delay 67ms;

:beep frequency=932 length=100ms;
:delay 110ms;
:beep frequency=740 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=622 length=201ms;
:delay 211ms;
:delay 67ms;

:beep frequency=932 length=100ms;
:delay 110ms;
:beep frequency=784 length=536ms;
:delay 546ms;
:delay 268ms;

:delay 67ms;

:beep frequency=1568 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=784 length=201ms;
:delay 211ms;
:delay 67ms;

:beep frequency=784 length=100ms;
:delay 110ms;
:beep frequency=1568 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=1480 length=201ms;
:delay 211ms;
:delay 67ms;

:beep frequency=1397 length=100ms;
:delay 110ms;
:beep frequency=1319 length=100ms;
:delay 110ms;
:beep frequency=1245 length=100ms;
:delay 110ms;
:beep frequency=1319 length=134ms;
:delay 144ms;
:delay 268ms;

:beep frequency=831 length=134ms;
:delay 144ms;
:delay 67ms;

:beep frequency=1109 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=1047 length=201ms;
:delay 211ms;
:delay 67ms;

:beep frequency=988 length=100ms;
:delay 110ms;
:beep frequency=932 length=100ms;
:delay 110ms;
:beep frequency=880 length=100ms;
:delay 110ms;
:beep frequency=932 length=134ms;
:delay 144ms;
:delay 268ms;

:beep frequency=622 length=134ms;
:delay 144ms;
:delay 67ms;

:beep frequency=740 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=622 length=201ms;
:delay 211ms;
:delay 67ms;

:beep frequency=784 length=100ms;
:delay 110ms;
:beep frequency=932 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=784 length=201ms;
:delay 211ms;
:delay 67ms;

:beep frequency=932 length=100ms;
:delay 110ms;
:beep frequency=1175 length=536ms;
:delay 546ms;
:delay 268ms;

:delay 67ms;

:beep frequency=1568 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=784 length=201ms;
:delay 211ms;
:delay 67ms;

:beep frequency=784 length=100ms;
:delay 110ms;
:beep frequency=1568 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=1480 length=201ms;
:delay 211ms;
:delay 67ms;

:beep frequency=1397 length=100ms;
:delay 110ms;
:beep frequency=1319 length=100ms;
:delay 110ms;
:beep frequency=1245 length=100ms;
:delay 110ms;
:beep frequency=1319 length=134ms;
:delay 144ms;
:delay 268ms;

:beep frequency=831 length=134ms;
:delay 144ms;
:delay 67ms;

:beep frequency=1109 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=1047 length=201ms;
:delay 211ms;
:delay 67ms;

:beep frequency=988 length=100ms;
:delay 110ms;
:beep frequency=932 length=100ms;
:delay 110ms;
:beep frequency=880 length=100ms;
:delay 110ms;
:beep frequency=932 length=134ms;
:delay 144ms;
:delay 268ms;

:beep frequency=622 length=134ms;
:delay 144ms;
:delay 67ms;

:beep frequency=740 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=622 length=201ms;
:delay 211ms;
:delay 67ms;

:beep frequency=784 length=100ms;
:delay 110ms;
:beep frequency=784 length=268ms;
:delay 278ms;
:delay 134ms;

:beep frequency=622 length=201ms;
:delay 211ms;
:delay 67ms;

:beep frequency=932 length=100ms;
:delay 110ms;
:beep frequency=784 length=536ms;
:delay 546ms;

StarWars

Код: You are not allowed to view links. Register or Login
:beep frequency=698 length=167ms;
:delay 177ms;
:beep frequency=698 length=167ms;
:delay 177ms;
:beep frequency=698 length=167ms;
:delay 177ms;
:beep frequency=932 length=1000ms;
:delay 1010ms;
:beep frequency=1397 length=1000ms;
:delay 1010ms;
:beep frequency=1245 length=167ms;
:delay 177ms;
:beep frequency=1175 length=167ms;
:delay 177ms;
:beep frequency=1047 length=167ms;
:delay 177ms;
:beep frequency=1865 length=1000ms;
:delay 1010ms;
:beep frequency=1397 length=500ms;
:delay 510ms;
:beep frequency=1245 length=167ms;
:delay 177ms;
:beep frequency=1175 length=167ms;
:delay 177ms;
:beep frequency=1047 length=167ms;
:delay 177ms;
:beep frequency=1865 length=1000ms;
:delay 1010ms;
:beep frequency=1397 length=500ms;
:delay 510ms;
:beep frequency=1245 length=167ms;
:delay 177ms;
:beep frequency=1175 length=167ms;
:delay 177ms;
:beep frequency=1245 length=167ms;
:delay 177ms;
:beep frequency=1047 length=667ms;
:delay 677ms;
:delay 333ms;

:beep frequency=698 length=167ms;
:delay 177ms;
:beep frequency=698 length=167ms;
:delay 177ms;
:beep frequency=698 length=167ms;
:delay 177ms;
:beep frequency=932 length=1000ms;
:delay 1010ms;
:beep frequency=1397 length=1000ms;
:delay 1010ms;
:beep frequency=1245 length=167ms;
:delay 177ms;
:beep frequency=1175 length=167ms;
:delay 177ms;
:beep frequency=1047 length=167ms;
:delay 177ms;
:beep frequency=1865 length=1000ms;
:delay 1010ms;
:beep frequency=1397 length=500ms;
:delay 510ms;
:beep frequency=1245 length=167ms;
:delay 177ms;
:beep frequency=1175 length=167ms;
:delay 177ms;
:beep frequency=1047 length=167ms;
:delay 177ms;
:beep frequency=1865 length=1000ms;
:delay 1010ms;
:beep frequency=1397 length=500ms;
:delay 510ms;
:beep frequency=1245 length=167ms;
:delay 177ms;
:beep frequency=1175 length=167ms;
:delay 177ms;
:beep frequency=1245 length=167ms;
:delay 177ms;
:beep frequency=1047 length=667ms;
:delay 677ms;

StarWarFinal

Код: You are not allowed to view links. Register or Login
:beep frequency=523 length=533ms;
:delay 543ms;
:beep frequency=698 length=1067ms;
:delay 1077ms;
:beep frequency=784 length=800ms;
:delay 810ms;
:beep frequency=831 length=133ms;
:delay 143ms;
:beep frequency=932 length=133ms;
:delay 143ms;
:beep frequency=831 length=1067ms;
:delay 1077ms;
:beep frequency=523 length=800ms;
:delay 810ms;
:beep frequency=523 length=267ms;
:delay 277ms;
:beep frequency=698 length=800ms;
:delay 810ms;
:beep frequency=784 length=267ms;
:delay 277ms;
:beep frequency=831 length=267ms;
:delay 277ms;
:beep frequency=523 length=267ms;
:delay 277ms;
:beep frequency=831 length=200ms;
:delay 210ms;
:beep frequency=523 length=200ms;
:delay 210ms;
:beep frequency=1047 length=133ms;
:delay 143ms;
:beep frequency=932 length=1600ms;
:delay 1610ms;
:beep frequency=523 length=533ms;
:delay 543ms;
:beep frequency=698 length=800ms;
:delay 810ms;
:beep frequency=784 length=267ms;
:delay 277ms;
:beep frequency=831 length=400ms;
:delay 410ms;
:beep frequency=698 length=133ms;
:delay 143ms;
:beep frequency=1047 length=400ms;
:delay 410ms;
:beep frequency=831 length=133ms;
:delay 143ms;
:beep frequency=1397 length=1067ms;
:delay 1077ms;
:beep frequency=698 length=533ms;
:delay 543ms;
:beep frequency=831 length=200ms;
:delay 210ms;
:beep frequency=784 length=200ms;
:delay 210ms;
:beep frequency=698 length=133ms;
:delay 143ms;
:beep frequency=1047 length=533ms;
:delay 543ms;
:beep frequency=1047 length=200ms;
:delay 210ms;
:beep frequency=831 length=200ms;
:delay 210ms;
:beep frequency=698 length=133ms;
:delay 143ms;
:beep frequency=523 length=533ms;
:delay 543ms;
:beep frequency=523 length=200ms;
:delay 210ms;
:beep frequency=523 length=200ms;
:delay 210ms;
:beep frequency=523 length=133ms;
:delay 143ms;
:beep frequency=698 length=533ms;
:delay 543ms;
:beep frequency=698 length=200ms;
:delay 210ms;
:beep frequency=698 length=200ms;
:delay 210ms;
:beep frequency=698 length=133ms;
:delay 143ms;
:beep frequency=698 length=533ms;
:delay 543ms;

StarTrek

Код: You are not allowed to view links. Register or Login
:beep frequency=698 length=714ms;
:delay 724ms;
:beep frequency=932 length=238ms;
:delay 248ms;
:beep frequency=1245 length=1429ms;
:delay 1439ms;
:beep frequency=1175 length=476ms;
:delay 486ms;
:beep frequency=932 length=357ms;
:delay 367ms;
:beep frequency=784 length=357ms;
:delay 367ms;
:beep frequency=1047 length=357ms;
:delay 367ms;
:beep frequency=1397 length=952ms;
:delay 962ms;

Missions Impossible

Код: You are not allowed to view links. Register or Login
:beep frequency=1245 length=167ms;
:delay 177ms;
:beep frequency=1047 length=167ms;
:delay 177ms;
:beep frequency=784 length=1333ms;
:delay 1343ms;
:beep frequency=1245 length=167ms;
:delay 177ms;
:beep frequency=1047 length=167ms;
:delay 177ms;
:beep frequency=740 length=1333ms;
:delay 1343ms;
:beep frequency=1245 length=167ms;
:delay 177ms;
:beep frequency=1047 length=167ms;
:delay 177ms;
:beep frequency=698 length=1333ms;
:delay 1343ms;
:beep frequency=622 length=167ms;
:delay 177ms;
:beep frequency=698 length=167ms;
:delay 177ms;
:delay 1333ms;

:beep frequency=831 length=167ms;
:delay 177ms;
:beep frequency=784 length=167ms;
:delay 177ms;
:beep frequency=1480 length=1333ms;
:delay 1343ms;
:beep frequency=831 length=167ms;
:delay 177ms;
:beep frequency=784 length=167ms;
:delay 177ms;
:beep frequency=1397 length=1333ms;
:delay 1343ms;
:beep frequency=831 length=167ms;
:delay 177ms;
:beep frequency=784 length=167ms;
:delay 177ms;
:beep frequency=1319 length=1333ms;
:delay 1343ms;
:beep frequency=1245 length=167ms;
:delay 177ms;
:beep frequency=1175 length=167ms;
:delay 177ms;
:delay 667ms;

Missions Impossible2

Код: You are not allowed to view links. Register or Login
:beep frequency=1175 length=75ms;
:delay 85ms;
:beep frequency=1245 length=75ms;
:delay 85ms;
:beep frequency=1175 length=75ms;
:delay 85ms;
:beep frequency=1245 length=75ms;
:delay 85ms;
:beep frequency=1175 length=75ms;
:delay 85ms;
:beep frequency=1245 length=75ms;
:delay 85ms;
:beep frequency=1175 length=75ms;
:delay 85ms;
:beep frequency=1245 length=75ms;
:delay 85ms;
:beep frequency=1175 length=75ms;
:delay 85ms;
:beep frequency=1175 length=75ms;
:delay 85ms;
:beep frequency=1245 length=75ms;
:delay 85ms;
:beep frequency=1319 length=75ms;
:delay 85ms;
:beep frequency=1397 length=75ms;
:delay 85ms;
:beep frequency=1480 length=75ms;
:delay 85ms;
:beep frequency=1568 length=75ms;
:delay 85ms;
:beep frequency=1568 length=150ms;
:delay 160ms;
:delay 300ms;

:beep frequency=1568 length=150ms;
:delay 160ms;
:delay 300ms;

:beep frequency=1865 length=150ms;
:delay 160ms;
:delay 150ms;

:beep frequency=1047 length=150ms;
:delay 160ms;
:delay 150ms;

:beep frequency=1568 length=150ms;
:delay 160ms;
:delay 300ms;

:beep frequency=1568 length=150ms;
:delay 160ms;
:delay 300ms;

:beep frequency=1397 length=150ms;
:delay 160ms;
:delay 150ms;

:beep frequency=1480 length=150ms;
:delay 160ms;
:delay 150ms;

:beep frequency=1568 length=150ms;
:delay 160ms;
:delay 300ms;

:beep frequency=1568 length=150ms;
:delay 160ms;
:delay 300ms;

:beep frequency=1865 length=150ms;
:delay 160ms;
:delay 150ms;

:beep frequency=1047 length=150ms;
:delay 160ms;
:delay 150ms;

:beep frequency=1568 length=150ms;
:delay 160ms;
:delay 300ms;

:beep frequency=1568 length=150ms;
:delay 160ms;
:delay 300ms;

:beep frequency=1397 length=150ms;
:delay 160ms;
:delay 150ms;

:beep frequency=1480 length=150ms;
:delay 160ms;
:delay 150ms;

:beep frequency=1865 length=150ms;
:delay 160ms;
:beep frequency=1568 length=150ms;
:delay 160ms;
:beep frequency=1175 length=1200ms;
:delay 1210ms;
:delay 75ms;

:beep frequency=1865 length=150ms;
:delay 160ms;
:beep frequency=1568 length=150ms;
:delay 160ms;
:beep frequency=1109 length=1200ms;
:delay 1210ms;
:delay 75ms;

:beep frequency=1865 length=150ms;
:delay 160ms;
:beep frequency=1568 length=150ms;
:delay 160ms;
:beep frequency=1047 length=1200ms;
:delay 1210ms;
:delay 150ms;

:beep frequency=932 length=150ms;
:delay 160ms;
:beep frequency=1047 length=150ms;
:delay 160ms;

PinkPanter

Код: You are not allowed to view links. Register or Login
:beep frequency=622 length=188ms;
:delay 198ms;
:beep frequency=659 length=188ms;
:delay 198ms;
:delay 750ms;

:beep frequency=740 length=188ms;
:delay 198ms;
:beep frequency=784 length=188ms;
:delay 198ms;
:delay 750ms;

:beep frequency=622 length=188ms;
:delay 198ms;
:beep frequency=659 length=188ms;
:delay 198ms;
:delay 94ms;

:beep frequency=740 length=188ms;
:delay 198ms;
:beep frequency=784 length=188ms;
:delay 198ms;
:delay 94ms;

:beep frequency=1047 length=188ms;
:delay 198ms;
:beep frequency=988 length=188ms;
:delay 198ms;
:delay 94ms;

:beep frequency=622 length=188ms;
:delay 198ms;
:beep frequency=659 length=188ms;
:delay 198ms;
:delay 94ms;

:beep frequency=988 length=188ms;
:delay 198ms;
:beep frequency=932 length=750ms;
:delay 760ms;
:delay 750ms;

:beep frequency=880 length=94ms;
:delay 104ms;
:beep frequency=784 length=94ms;
:delay 104ms;
:beep frequency=659 length=94ms;
:delay 104ms;
:beep frequency=587 length=94ms;
:delay 104ms;
:beep frequency=659 length=750ms;
:delay 760ms;

Simpsons

Код: You are not allowed to view links. Register or Login
:delay 47ms;

:beep frequency=1047 length=563ms;
:delay 573ms;
:beep frequency=1319 length=375ms;
:delay 385ms;
:beep frequency=1480 length=375ms;
:delay 385ms;
:beep frequency=1760 length=188ms;
:delay 198ms;
:beep frequency=1568 length=563ms;
:delay 573ms;
:beep frequency=1319 length=375ms;
:delay 385ms;
:beep frequency=1047 length=375ms;
:delay 385ms;
:beep frequency=880 length=188ms;
:delay 198ms;
:beep frequency=740 length=188ms;
:delay 198ms;
:beep frequency=740 length=188ms;
:delay 198ms;
:beep frequency=740 length=188ms;
:delay 198ms;
:beep frequency=784 length=750ms;
:delay 760ms;

Так же есть более сложные скрипты полных произведений:

AC/DC

Код: You are not allowed to view links. Register or Login
# Thunderstruck AC/DC
# =================
:local n11 63,66;
:local n12 64,67;
:local n21 71,69,68,69,68,66,68,64,66,63;
:local n22 64,63;

:local n11 ($n11,$n11);
:local n12 ($n12,$n12);
:local n1 ($n11,$n11,$n12,$n12);
:local n2 ($n21,$n22,$n22,$n22);
:local notes ($n1,$n1,$n2,$n2);
 
:local ticks 2;
:local speed 55ms;
:local stacc 5ms;
# Transposition
:local transpose -48;
# ==============================
# Don't change this:
:local frqtab 8372,8869,9397,9956,10548,11175,11839,12543,13288,14080,14916,15804;
:local n0; :local n;
:local d0; :local d;
:local l;
:local midi;
:local i;
:local octa;
:local frq;
:for i from=0 to= ([:len $notes]-1) do={
:set midi [:pick $notes $i];
:set midi ($midi + $transpose);
:set octa 0;
:while ( $midi < 60) do={:set midi ($midi + 12); :set octa ($octa + 1   ); };
:set midi ($midi - (12 * ($midi /12)));
:set frq [:tonum [:pick $frqtab $midi]];
:set frq ($frq>>($octa));
:set d0 $ticks;
:set d ($d0 * $speed );
:set l ($d0 * ($speed - $stacc));
:beep fr=$frq le=$l;
:delay $d;
:set midi 59;
:set midi ($midi + $transpose);
:set octa 0;
:while ( $midi < 60) do={:set midi ($midi + 12); :set octa ($octa + 1   ); };
:set midi ($midi - (12 * ($midi /12)));
:set frq [:tonum [:pick $frqtab $midi]];
:set frq ($frq>>($octa));
:set d0 $ticks;
:set d ($d0 * $speed );
:set l ($d0 * ($speed - $stacc));
:beep fr=$frq le=$l;
:delay $d;
}

Bach

Код: You are not allowed to view links. Register or Login
# Solfeggietto c minor for solo Mikrotik
# H 220, Wq. 117: 2
# C. P. E. Bach
# Transcription MikroTourette 2017
#
:local notes 51,48,51,55,60,63,62,60,59,55,59,62,67,65,63,62;
:local notes ($notes, 63,60,63,67,72,75,74,72,74,72,71,69,67,65,63,62);
:local notes ($notes, 63,60,63,67,72,75,74,72,71,67,71,74,79,77,75,74);
:local notes ($notes, 75,72,75,79,84,87,86,84,86,84,83,81,79,77,75,74);
:local notes ($notes, 75,72,67,63,60,84,79,75,80,53,56,60,65,68,72,75);
:local notes ($notes, 74,70,65,62,58,82,77,74,79,51,55,58,63,67,70,74);

:local notes ($notes, 72,69,68,69,72,69,68,69,75,72,67,69,75,72,67,69);
:local notes ($notes, 74,72,66,69,81,72,66,69,78,72,62,69,72,69,66,62);
:local notes ($notes, 70,43,46,50,55,58,57,55,54,50,54,57,62,60,58,57);
:local notes ($notes, 58,55,58,62,67,70,69,67,69,67,66,64,62,60,58,57);
:local notes ($notes, 58,55,58,62,67,70,69,67,66,62,66,69,74,72,70,69);
:local notes ($notes, 70,67,70,74,79,82,81,79,81,79,78,76,74,72,70,69);
:local notes ($notes, 70,67,70,74,79,74,70,67,53,79,74,71,67,71,74,79);
:local notes ($notes, 72,67,79,67,72,67,79,67,71,67,77,67,71,67,77,67);
:local notes ($notes, 75,72,75,79,84,79,75,72,58,84,79,76,72,76,79,84);
:local notes ($notes, 77,72,84,72,77,72,84,72,76,72,82,72,76,72,82,72);
:local notes ($notes, 80,41,44,48,53,56,55,53,52,48,52,55,60,58,56,55);
:local notes ($notes, 56,53,56,60,65,68,67,65,67,65,64,62,60,58,56,55);
:local notes ($notes, 56,53,56,60,65,68,67,65,64,60,64,67,72,70,68,67);
:local notes ($notes, 68,65,68,72,77,80,79,77,79,77,76,74,72,70,68,67);
:local notes ($notes, 68,77,72,68,65,72,68,65,60,68,65,60,56,65,60,56);
:local notes ($notes, 49,80,77,76,77,79,77,76,77,48,68,65,64,65,67,65);
:local notes ($notes, 64,65,47,86,77,79,80,79,77,75,74,75,79,84,79,82);
:local notes ($notes, 80,79,77,75,75,74,75,74,75,74,75,74,72,67,79,67);
:local notes ($notes, 72,67,79,67,71,67,77,67,71,67,77,67,70,67,76,67);
:local notes ($notes, 70,67,76,67,69,75,84,75,69,75,84,75,68,65,74,65);
:local notes ($notes, 68,65,74,65,67,73,82,73,67,73,82,73,66,63,72,63);
:local notes ($notes, 66,63,72,63,65,72,84,72,65,72,84,72,63,72,75,79);
:local notes ($notes, 84,79,75,72,79,75,72,67,77,74,71,65,63,48,51,55);
:local notes ($notes, 60,63,62,60,59,55,59,62,67,65,63,62,63,60,63,67);
:local notes ($notes, 72,75,74,72,74,72,71,69,67,65,63,62,63,60,63,67);
:local notes ($notes, 72,75,74,72,71,67,71,74,79,77,75,74,75,72,75,79);
:local notes ($notes, 84,87,86,83,84,79,75,74,72,67,63,62,60);

:local speed 50ms;
:local stacc 10ms;
:local transpose -48;
:local frqtab 8372,8869,9397,9956,10548,11175,11839,12543,13288,14080,14916,15804;
:local n0; :local n;
:local d0; :local d;
:local l;
:local midi;
:local i;
:local octa;
:local frq;
:for i from=0 to= ([:len $notes]-1) do={
:set midi [:pick $notes $i];
:set midi ($midi + $transpose);
:set octa 0;
:while ( $midi < 60) do={:set midi ($midi + 12); :set octa ($octa + 1   ); };
:set midi ($midi - (12 * ($midi /12)));
:set frq [:tonum [:pick $frqtab $midi]];
:set frq ($frq>>($octa));
:set d0 2;
:if ($i >371 && $i<380) do={:set d0 1};
:if ($i =336) do={:set d0 16};
:if ($i =345) do={:set d0 16};
:if ($i =354) do={:set d0 16};
:if ($i =371) do={:set d0 8};
:if ($i =524) do={:set d0 16};

:set d ($d0 * $speed );
:set l ($d0 * ($speed - $stacc));
# :put $midi;
# :put $frq;
# :put $octa;
:beep fr=$frq le=$l;
:delay $d;
}
« Последнее редактирование: Марта 02, 2018, 02:53:43 pm от Дмитрий »


Contact You are not allowed to view links. Register or Login